Inicio Foros Sistemas operativos Linux Conectar con unidad CIFS en Linux Red Hat Enterprise 6.4

  • Este debate tiene 4 respuestas, 2 mensajes y ha sido actualizado por última vez el hace 2 meses por Varios.
Viendo 5 entradas - de la 1 a la 5 (de un total de 5)
  • Autor
    Entradas
  • #43554
    Varios
    Moderador

    Hola, tengo un servidor con Linux Red Hat y al intentar montar una unidad CIFS en una carpeta, me muestra este error:

    mount.cifs kernel mount options: ip=19.168.1.100,unc=\\servidorcifs\backup,,ver=1,user=usuario,prefixpath=oracle,pass=********
    mount error(112): Host is down
    Refer to the mount.cifs(8) manual page (e.g. man mount.cifs)

    El comando que uso para montar la unidad es:

    mount -t cifs -v -o user=usuario,password=contraseña //servidorcifs/backup/oracle /backup_oracle

    Tengo creada la carpeta /backup_oracle en el servidor Linux, para que monte ahí la unidad CIFS.

    #43555
    alonsojpd
    Superadministrador

    ¿Qué versión de Linux Red Hat tienes?

    Puedes obtenerla con el comando:

    cat /etc/redhat-release

    O también con este otro comando:

    more /etc/issue

    #43556
    Varios
    Moderador

    Me devuelve:

    Red Hat Enterprise Linux Server release 6.4 (Santiago)

    #43557
    alonsojpd
    Superadministrador

    La versión de Red Hat 6.4 no soporta SMB versión 2.0 ni superior, tal vez sea por eso.

    Tienes que comprobar en el servidor SMB al que te estás conectando, el que te presenta el recurso CIFS, en tu comando, el servidor servidorcifs y habilitar el uso de SMB versión 1.0.

    Algunos servidores CIFS, por seguridad, desactivan SMB 1.0, dado que actualmente va por la versión 3.0.

    Otra opción, pero mucho más costosa y «traumática», es pasar el servidor a Linux Red Hat 7.0, esta versión de Linux sí que admite SMB v3.

    #43558
    Varios
    Moderador

    No me es posible cambiar a Linux Red Hat 7. El servidor usa muchos servicios que no se pueden volver a recrear.

    Pero sí que he visto que, efectivamente, el servicio CIFS tenía desactivado el SMB v1. Lo he activado y ya me crea perfectamente la unidad.

    Solucionado.

    Muchísimas gracias.

Viendo 5 entradas - de la 1 a la 5 (de un total de 5)
  • Debes estar registrado para responder a este debate.