Inicio Foros Lenguajes de programación, desarrollo, código fuente Python Error actualizar pip ValueError Unable find resource t64.exe package [RESUELTO]

  • Este debate tiene 2 respuestas, 2 mensajes y ha sido actualizado por última vez el hace 4 meses por Varios.
Viendo 3 entradas - de la 1 a la 3 (de un total de 3)
  • Autor
    Entradas
  • #47671
    Varios
    Moderador

    Hola, cuando intento actualizar pip (el instalador de paquetes de Python) desde la línea de comandos en un equipo Windows 10 con el comando:

    python.exe -m pip install –upgrade pip

    Me muestra este error:

    C:\Program Files>python.exe -m pip install –upgrade pip
    Requirement already satisfied: pip in c:\users\facturacion\appdata\roaming\python\python39\site-packages (20.3.3)
    Collecting pip
    Using cached pip-22.0.4-py3-none-any.whl (2.1 MB)
    Installing collected packages: pip
    Attempting uninstall: pip
    Found existing installation: pip 20.3.3
    Uninstalling pip-20.3.3:
    Successfully uninstalled pip-20.3.3
    Rolling back uninstall of pip
    Moving to c:\users\facturacion\appdata\roaming\python\python39\scripts\pip.exe
    from C:\Users\facturacion\AppData\Local\Temp\pip-uninstall-phs0pnxy\pip.exe
    Moving to c:\users\facturacion\appdata\roaming\python\python39\scripts\pip3.9.exe
    from C:\Users\facturacion\AppData\Local\Temp\pip-uninstall-phs0pnxy\pip3.9.exe
    Moving to c:\users\facturacion\appdata\roaming\python\python39\scripts\pip3.exe
    from C:\Users\facturacion\AppData\Local\Temp\pip-uninstall-phs0pnxy\pip3.exe
    Moving to c:\users\facturacion\appdata\roaming\python\python39\site-packages\pip-20.3.3.dist-info\
    from C:\Users\facturacion\AppData\Roaming\Python\Python39\site-packages\~ip-20.3.3.dist-info
    Moving to c:\users\facturacion\appdata\roaming\python\python39\site-packages\pip\
    from C:\Users\facturacion\AppData\Roaming\Python\Python39\site-packages\~ip
    ERROR: Exception:
    Traceback (most recent call last):
    File «C:\Users\facturacion\AppData\Roaming\Python\Python39\site-packages\pip\_internal\cli\base_command.py», line 224, in _main
    status = self.run(options, args)
    File «C:\Users\facturacion\AppData\Roaming\Python\Python39\site-packages\pip\_internal\cli\req_command.py», line 180, in wrapper
    return func(self, options, args)
    File «C:\Users\facturacion\AppData\Roaming\Python\Python39\site-packages\pip\_internal\commands\install.py», line 394, in run
    installed = install_given_reqs(
    File «C:\Users\facturacion\AppData\Roaming\Python\Python39\site-packages\pip\_internal\req\__init__.py», line 82, in install_given_reqs
    requirement.install(
    File «C:\Users\facturacion\AppData\Roaming\Python\Python39\site-packages\pip\_internal\req\req_install.py», line 816, in install
    install_wheel(
    File «C:\Users\facturacion\AppData\Roaming\Python\Python39\site-packages\pip\_internal\operations\install\wheel.py», line 837, in install_wheel
    _install_wheel(
    File «C:\Users\facturacion\AppData\Roaming\Python\Python39\site-packages\pip\_internal\operations\install\wheel.py», line 747, in _install_wheel
    generated_console_scripts = maker.make_multiple(scripts_to_generate)
    File «C:\Users\facturacion\AppData\Roaming\Python\Python39\site-packages\pip\_vendor\distlib\scripts.py», line 418, in make_multiple
    filenames.extend(self.make(specification, options))
    File «C:\Users\facturacion\AppData\Roaming\Python\Python39\site-packages\pip\_internal\operations\install\wheel.py», line 483, in make
    return super(PipScriptMaker, self).make(specification, options)
    File «C:\Users\facturacion\AppData\Roaming\Python\Python39\site-packages\pip\_vendor\distlib\scripts.py», line 407, in make
    self._make_script(entry, filenames, options=options)
    File «C:\Users\facturacion\AppData\Roaming\Python\Python39\site-packages\pip\_vendor\distlib\scripts.py», line 307, in _make_script
    self._write_script(scriptnames, shebang, script, filenames, ext)
    File «C:\Users\facturacion\AppData\Roaming\Python\Python39\site-packages\pip\_vendor\distlib\scripts.py», line 242, in _write_script
    launcher = self._get_launcher(‘t’)
    File «C:\Users\facturacion\AppData\Roaming\Python\Python39\site-packages\pip\_vendor\distlib\scripts.py», line 386, in _get_launcher
    raise ValueError(msg)
    ValueError: Unable to find resource t64.exe in package pip._vendor.distlib
    WARNING: You are using pip version 20.3.3; however, version 22.0.4 is available.
    You should consider upgrading via the ‘C:\Program Files\python.exe -m pip install –upgrade pip’ command.

    ¿A qué puede ser debido?

    #47672
    alonsojpd
    Superadministrador

    Prueba a ejecutar estos comandos, si puedes intenta abrir la ventana de MS-DOS en modo administrador:

    python -m pip uninstall pip
    python -m ensurepip
    python -m pip install -U pip

    #47673
    Varios
    Moderador

    Genial, perfecto, solucionado con esos comandos.

    Muchísimas gracias.

Viendo 3 entradas - de la 1 a la 3 (de un total de 3)
  • Debes estar registrado para responder a este debate.